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This manual introduces you to SAP2000. The step-by-step instructions guide you through
development of your first model. The intent is to demonstrate the fundamentals and to show how
quickly and easily a model can be created using the program. Completing the tutorial will give
you hands-on experience working with SAP2000, which for most people is the quickest way to
become familiar with the program.

What is SAP20007?

SAP2000 is a general purpose finite element program which performs the static or dynamic,
linear or nonlinear analysis of structural systems. It is also a powerful design tool to design
structures following AASHTO specifications, ACI and AISC building codes. These features, and
many more make SAP2000 the state-of-the-art in structural analysis program.

The SAP2000 graphic user interface (GUI) is used to model, analyze, design, and display the
structure geometry, properties and analysis results. The analysis procedure can be divided into
three parts:

1. Preprocessing.
2. Solving.
3. Postprocessing

Part | Preprocessing:
In preprocessing, the following information is needed by SAP2000.

Choosing the units for this project.

Setting up geometry.

Defining material and member section properties.
Assigning member section properties and element releases.
Defining load cases.

Assigning load magnitudes.

Assigning restraints.
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PART 11 Solving In this part SAP2000 will assemble and solve the global matrix.

PART Il Postprocessing.
The main options in postprocessing are:

Displaying the deformed shape.

Displaying the member forces.

Printing the results.

Designing the structural members and checking the safety of a design.
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5. Modifying the structure.

Exercice 1: Analysis of Simple Truss Structure using SAP2000

The following exercise illustrates the joint equilibrium method for a simple truss.

100 b

Solve using SAP2000: Determine the force in members AB and AC shown in this figure.
Given that the angle of member AC with the vertical is equal 60°, while the angle formed by
member AB and the vertical direction is equal 90°. The weight applied is w=100Ib. State
whether is in tension or compression.

In order to solve the problem joint A may be isolated (method of joint). Observe that at this joint
there is an externally applied force of 100-1b which is vertical and pulls down on the joint. On
the other hand, member AC is pulling up on the joint trying to keep it from moving from its
original position. Similarly, member AB also applies a force on the joint in order to keep it from
moving from its original position.

The structure shown in the figure above is formed by truss members that can only carry forces
along the longitudinal axes of the members, then the force in member AC will be directed from
point A to point C. Similarly the force in member AB will be directed along the axis of AB.

The forces in these members can be calculated using the joint equilibrium method at joint A in
that the horizontal components of the forces applied at the joint must cancel each other and the
vertical components of the forces applied on the joint must also cancel each other. That is the
condition of equilibrium of forces, XFX = 0 and ZFy= 0, must be satisfied at joint A.



Therefore, SF,=0: AB+ACsin60°=0
and
LF,=0: ACcos60°+ W=0 .

In order to maintain equilibrium in the structure, the second equation for vertical components
gives the force in member AC as

AC =-=W/cos60° =-200 |b.
X

S
Now using the results for AC in the first equation Joint A for horizontal components, the T 4+ )
force in member 4B is determined as >
AC CONVENTION
AB =-ACsin60°=173.21 Ib. “-\_
“\_ Joint A
AB
W

Solve the problem using SAP2000

About SAP2000 v17 : The Software is available to all engineering students during open lab hours (Room
E344). You can also download an evaluation version from http://www.csiamerica.com

Step 1: Begin a New Model
Start SAP2000 from File menu > New Model command or the New Model button.
- Unit: The form shown in Figure will display. Verify that the default units are set to Ib, in, F.

When a new model is started, SAP2000 will ask the user to specify a set of units. Those units become the “base
units” for the model.

Grid Spacing - Determine the appropriate number of grid line and grid spacing to locate the joints of the
truss. Click on Grid only from the set of templates.
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The Quick Grid Lines window is used to specify the grids and spacing in the X, Y and
Z directions.

Number of Grid lines: Set the number of grid lines to 3 for the X direction, and to 3 for
the Y and 3 for Z directions.

Grid Spacing: For the truss shown below, assume a length for the distance between
joint B and C and then use a sine relationship from the trigonometry of the structure,
yielding to a simple relation: If by instance you assume BC to be 24 ft, Then AB is

41.5692 ft. in our Grid Spacing section we will have X direction is 41.56ft, Y and Z 24ft.

First Grid Line location: make sure that these values are all set to zero for this futorial.
Click the OK button to accept the changes, and the program will appear as shown in
shown 1in the figure below.

Note that the grids appear i two view windows tiled verticallv. an X-Z “Plan” View on
the left and a 3-D View on the right. c
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The “Plan” view 1s active in Figure. When the window 1s active, the display title bar 1s hughlighted. Seta
view active by clicking anywhere 1n the view window.

Note that the Global Axes are displayed as well, and that the Z positive 1s in the “up™ direction. When

SAP2000 refers to the direction of gravity, this 1s in the negative Z direction, or “down.”



Step 2: Draw Frame Objects:

Make sure that the X-Z Plane view is active (Click inside the window to activate). This view should be in
the left window. Also check that the Snap to Points and Grid Intersections command is active

This will assist in accurately positioning the frame objects. Alternatively, use the Draw menu > Snap to >
Points and Grid Intersections command. By default, this command is active.

Now on the left bar of the window, there are several drawing tools. Click the Draw Frame/Cable button
the Properties of Object pop-up form for frames will appear and Start drawing the frame as shown in

Figure.
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Once you have drawn the members Press the Esc key on the key-board to exit the Draw
Frame/Cable/Tendon command.

Step 3 Assign joint restraints

Select both joints B and C. Once selected, we go to the bar menu on the top and select Assign -=laint ->
Restraints, and select the pin joint restraint. (Figure)

Make sure you have selected the second Fast Restraint which is the one representing a pinned

connection, and then click OK.



Note: A joint restraint is the same as a joint support. It is a rigid connection of the joint to the ground.
Pinned: All three translational degrees of freedom are restrained.
Step 4 Assign Load

|

Once your joints are restrained, is time to assign the applied load. To apply the load, first select the node
where it is to be applied, and go to Assign -> Joint Loads -> Forces.

The Joint Forces window shows Load Pattern Name and the different axes. Assign the type of load
applied to the truss by entering the value of the load in the proper direction, taking in consideration the
axes used in the model. On the Load Pattern Name drop down menu, click on the plus sign to add a new
load type for load applied. On the Define Load Patterns window, click on the Load Pattern Name box and
type a name for the load, for example LIVE, change the type on the next box to LIVE, and then click on
Add New Load Pattern. Then click Ok. For this example, the load is applied in the negative direction of z,
with a magnitude
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The force then will be displayed in the node where it is applied for verification purposes. If more than
one force is applied to the structure, then the model will be refreshed and only display the most recent
force applied, so the previous applied forces will still be there, but just not visible.
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Step 5: Run the analysis

Once all the forces are applied, you are ready to run the analysis of the model. Go to Analyze -> Run
Analysis, or in the toolbar just look for the button that has the play shape to start the analysis. Once the
Set Cases to Run window is displayed, you can select which cases to analyze and which ones to ignore.
To accelerate analysis, the Modal case can be set to not run by highlighting it and clicking on the Run/Do
not Run Case button.
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Now click on the Run Now button. SAP2000 will prompt different results of the analysis
according to what is requested. Reactions, member forces, moments, deformations and member
displacements are available for display.

Step 6 Show Forces/Stresses - Frames/Cables/Tendons

Use the Display menu > Show Forces/Stresses > Frames/Cables/Tendons command to display
column, beam, brace, cable, or tendon forces directly on the SAP2000 model.

1. Click the Display menu > Show Forces/Stress > Frames/Cables/Tendons command to display
the Member Force Diagram for Frames form. Use the form to specify the parameters for the
display. (See Figure)

= Case/Combo Name drop-down list. Choose the Load Case or Combination to be
displayed.

= Multivalued Options. The type of load case/combination determines the option(s)
available:

For multi-mode cases, choose the mode number for which results are to be shown.
For multi-step cases, choose the step number, time step, or frequency step; choose
Envelope to view the maximum and/or minimum results over all steps.

AN

= Component options. Specify which component of force is to be displayed. Only one
component can be displayed at a time.

= Scaling options. Select the Auto option to have SAP2000 automatically determine a
scaling factor. Select the Scale Factor option to specify a scale factor.

= Fill diagram, Show Values on Diagram and Show Deformed Shape check boxes. Use
these options to display the force diagrams filled with no text values, unfilled with no text
values, unfilled with text values and on a deformed shape.

v To display force diagrams filled with no text values, check the Fill Diagram check box.
Note that if the Show Values on Diagram check box is checked, uncheck it first before
checking the Fill Diagram check box.

v To display force diagrams unfilled with text values, check the Show Values on Diagram
check box. Note that if the Fill Diagram check box is checked, uncheck it first before
checking the Show Values on Diagram check box.

v To display force diagrams unfilled with no text values, uncheck both the Fill Diagram
and Show Values on Diagram check boxes.

v Check the Show Deformed Shape check box to show the model as a deformed shape.
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2. Click Grid Only

[ B Quick Grid Lines [
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X direction 4
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Z direction 0.
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- 4. Select Draw Frame/Cable tool

[: 5. Draw the sample truss in Figure 1 starting from
0 joint1,23

P
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: (1) (2)
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4. Assign joint restraints : select joint 1 and 3 click on Assigh menu
Joints/Restraints

H SAP2000 v17.3.0 Ultimate - (Untitled)
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Select Pinned restraints: All three translational degrees of freedom are restrained.
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Assign Load: Once your joints are restrained, is time to assign the applied load. To apply
the load, first select the node where it is to be applied, and go to Assign -> Joint Loads -
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> Forces.
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The Joint Forces window shows Load Pattern Name and the different axes. Assign the type of load
applied to the truss by entering the value of the load in the proper direction, taking in consideration the
axes used in the model. On the Load Pattern Name drop down menu, click on the plus sign to add a new
load type for load applied. On the Define Load Patterns window, click on the Load Pattern Name box and
type a name for the load, for example LIVE, change the type on the next box to LIVE, and then click on
Add New Load Pattern. Then click Ok. For this example, the load is applied in the negative direction of z,
with a magnitude
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Click Ok the force then will be displayed in the node where it is applied for verification purposes.

Release Moments

Select all members-> Assign-> Frame-> Release/Partial fixidity -> select moment 22 and moment 33->o0k
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Run the Analysis:

Once all the force are applied, you are ready to run the analysis of the Model. First save your Model
then Go to Analyze > Run—> Analysis. Set the Model case to not run by highlighting it and clicking on
the Run/Do not run case Button
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After running the Model You will see a deformed shape of your structure
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Show Forces/Stresses - Frames/Cables/Tendons

Click the Display menu > Show Forces/Stress > Frames/Cables/Tendons
command to display the Member Force Diagram. Make sure that axial force and

show values on diagram are selected. Click OK
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2. Click Grid Only
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4. Select Draw Frame/Cable tool

r_1‘ 5. Draw the sample truss in Figure 2
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4. Assign joint restraints : select joint 1 and 3 click on Assign menu
Joints/Restraints
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Select Pinned restraints: All three translational degrees of freedom are restrained.
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The Joint Forces window shows Load Pattern Name and the different axes. Assign the type of load
applied to the truss by entering the value of the load in the proper direction, taking in consideration the
axes used in the model. On the Load Pattern Name drop down menu, click on the plus sign to add a new
load type for load applied. On the Define Load Patterns window, click on the Load Pattern Name box and
type a name for the load, for example LIVE, change the type on the next box to LIVE, and then click on
Add New Load Pattern. Then click Ok. For this example, the load is applied in the negative direction of z,
with a magnitude
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Assign Load: Once your joints are restrained, is time to assign the applied load. To apply
the load, first select the node where it is to be applied, and go to Assign -> Joint Loads -
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Release Moments

Select all members-> Assign-> Frame-> Release/Partial fixidity -> select moment 22 and moment 33->o0k
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Run the Analysis:

Once all the force are applied, you are ready to run the analysis of the Model. First save your Model
then Go to Analyze > Run—> Analysis. Set the Model case to not run by highlighting it and clicking on
the Run/Do not run case Button
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After running the Model You will see a deformed shape of your structure
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2. Click Grid Only
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4. Select Draw Frame/Cable tool
5. Draw the sample truss in Figure 3
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6. Assign joint restraints : select joint click on Assign menu
Joints/Restraints

H SAP2000 v17.3.0 Ulimate - (Untitled)

File Edit View Define Draw  Select | Assign | Analyze Display Design Options Tools Help

*. loint 4 ||$' Restraints...

DY HEoa|Flalrd

'}_[HX-Z @vy-18 ‘I \: Frame k 03:; Constraints...

¥ cable r | *%1  Springs...

Select Pinned restraints: All three translational degrees of freedom are restrained.

”
3{ Joint Restraints

Restraints in Joint Local Directions

—

>

—
—
m|
—

Translation 1 [| Rotation about 1
Translation 2 [| Rotation about 2

gy Ry

Translation 3 [| Rotation about 3

R E— Fast Restraints

B 2

[ Cancel ]

ROTATE THE SUPPORTS TO WORK ACCONDINTLY WITH THE MODEL

Select the supports -> Assign -> Joint-> Local Axis -> change the Y value to 90.



L1 L J
- B
3¢ Joint Local Axis ) n) (R
g g ey
1 Rotations in Degrees s | . .
E =
Rotation about Z o 7
N | N
Rotation about 20
Rotation about X 0
[[] Advanced Axes Advanced
L [] usedefault (Global) .
Fes =
[ DK J [ Cancel ] i |

Assign Load: Once your joints are restrained, is time to assign the applied load. To apply
the load, first select the node where it is to be applied, and go to Assign -> Joint Loads -

> Forces.

r "
3{ Joint Forces

2

Load Pattern Mame

Bl

Loads Coordinate System
Force Global X -24| [ GLOBAL ~ ]
F Global %" 0.
orce Globa Options

Force Global Z 0. Add to Existing Loads

Moment about Global X 0. @ Replace Existing Loads
Delete Existing Loads

Moment about Global 0.

Moment about Global Z 0. | ok | | cancel

Units
[Khl. m, C v]

The Joint Forces window shows Load Pattern Name and the different axes. Assign the type of load
applied to the truss by entering the value of the load in the proper direction, taking in consideration the
axes used in the model. On the Load Pattern Name drop down menu, click on the plus sign to add a new



load type for load applied. On the Define Load Patterns window, click on the Load Pattern Name box and
type a name for the load, for example LIVE, change the type on the next box to LIVE, and then click on
Add New Load Pattern. Then click Ok. For this example, the load is applied in the negative direction of z,
with a magnitude

- B

Define Load Patterns

- atterns — Click. To: / \
Self wWeight Auto Lateral ‘ 3 )
1 Joad Pattem Name @ Multiplier Load Pattern Add New Load Pate I
< ;I todify Load Pattern |

[Cwve |o =
DEAD DEAD ] ﬂ rodify Lateral Load Pattern... I
Delets Load Pattem I
B
Show Load Pattern Motes. .. I

—F x Joint Forces u1

S— | e— o
Load Pattern Mame Unitz
[|qu - [KN. m, C v]
Loads Coordinate System
Force Global X a [GL‘DB’"‘L h ]
Force Global v 0.
Options
Force Global Z -2 ") Add to Existing Loads
Moment about Global X o. @ Replace Existing Loads
(71 Delete Existing Loads
Moment about Global v 0.
Moment about Global Z 0. [ 0K ] [ Cancel i

Click Ok the force then will be displayed in the node where it is applied for verification purposes.
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RELEASE MOMENTS

Select all members-> Assign-> Frame-> Release/Partial fixidity -> select moment 22 and moment 33-
>ok

i x Assign Frame Releases x|
Frame Releases
Frame Partial Fixity Springs
Start End Start End
Axial Load 0 [E
Shear Force 2 (Major) 0 [
Shear Force 3 (Minor} 0 [ E
Torsion 0 [ [
Moment 22 (Minor) 0 0
Moment 33 (Major) 0 0
[] MoReleases Units [KN, m, C -
n.
|
" J

Run the Analysis:



Once all the force are applied, you are ready to run the analysis of the Model. First save your Model

then Go to Analyze 2 Run—-> Analysis. Set the Model case to not run by highlighting it and clicking on
the Run/Do not run case Button

|14
| ———
'
9 3¢ Set Load Cases to Run
—
Click to:
Case Type Status Action R Not R
Do Not Run
_5 MODAL Modal Not Run Do Mot Run Show Case
Live Linear Static Not Run Run - - -
Lielete Hesuns ror Lase
| RunDo Not Run Al
| Deete Al Results
[ Show Load Case Tree...
Analysis Monitor Options [] Modet-alive
) Always Show [ Fun Now
i () Never Show
| ok | [ cancel

@ ShowAfter 4

seconds

After running the Model You will see a deformed shape of your structure
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Ac join ) Fazy= Fazissd
LS
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F;Lg NJ\G = - ;55‘\‘\}
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Faz- -125 KN

Plug Eve volug ok Faz into aquolion T to find R

—Fa ~Fazwe0 =0
-Fau = (-128)(.8) =0
Fai=+loowrn
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membe(2) bos an inkerrad fore. & - 135 Ky (Compression)
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~ Example 5
4 : WL 6= 20/W _ 7809

o @ L VzoZi 16 =. 625

i2)

| 206e 2 ot ‘BQSMJ

i

Finp InTeapaL Foetes UsiNG METHODS OF JOINTS

NODE 3 -
9\ Fx=0

EFy=0 =25 +Fez b =0 =, Fs3 = 25 _ 40k
L6345

~Foy - Fozleme)=0 gl

il —Faz-(40 )(.3809) = O
Fas = - 31.84y
) o
NODE 5 L&ou rose. 3 Unouk (Fge  Fs ngg)Qr‘d_ QJQQLLLQ*

F154_ <——o0
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FSI
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| d
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Problem 4 :

Solve using SAP2000: Determine the force in each member of the warren truss show. State whether is in
tension or compression

6 kips G kips

Solution:

FAB =7.50 kips C
Fac=4.5kis T
Fgc=7.5kips T
FBD=9-OO kips C
FCD =0 kIpS

FCE =9.00 kIpS T
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